
 

 

           แผนการสอน/แผนการเรียนรู้ภาคทฤษฎี 

 

แผนการสอน/การเรียนรู้ภาคทฤษฎี หน่วยที่ 15 

ชื่อวิชา      เทคนิคการสร้างภาพเคล่ือนไหวคอมพิวเตอร์ สอนสัปดาห์ที่  15 

ชื่อหน่วย   การเผยแพร่ช้ินงานท่ีสร้าง 
     

คาบรวม  60 

    ช่ือเรื่อง         ความรู้เกี่ยวกับการพับลิชช้ินงานได้   ความรู้กี่ยวกับการพับลิช

ช้ินงานเป็นไฟล์ แฟลชมูฟวี่ (flash movie)  ความรู้เกี่ยวกับพับลิชช้ินงานเป็นไฟล์ 
HTML  

จ านวนคาบ 4 

หัวข้อเรื่อง 
จุดประสงค์เชิงพฤติกรรม: 
 ด้านความรู้ 

1. ความรู้เกี่ยวกับการพับลิชช้ินงานได้ 
2. ความรู้กี่ยวกับการพับลิชช้ินงานเป็นไฟล์ แฟลชมูฟวี่ (flash movie) ได้ 
3. ความรู้เกี่ยวกับพับลิชช้ินงานเป็นไฟล์ HTML ได้ 

 
ด้านทักษะ 
    1.   ท าการเผยแพร่ช้ินงานในรูปแบบ (flash movie)  และ HTML ได้ 

 
ด้านคุณธรรม จริยธรรม/บูรณาการเศรษฐกิจพอเพียง 

1. เตรียมความพร้อมด้าน วัสดุ  อุปกรณ์สอดคล้องกับงานได้อย่างถูกต้อง 
2. ปฏิบัติงานได้อย่างถูกต้อง และส าเร็จภายในเวลาท่ีก าหนดอย่างมีเหตุและผลตามหลักปรัชญาเศรษฐกิจ

พอเพียง    
 

สาระส าคัญ 

            ในบทนี้จะเป็นการแปลงงาน Flash ของเราเพื่อน าไปเผยแพร่ ซึ่งโปรแกรม Flash สามารถแปลงไฟล์งาน
ให้เราได้หลายรูปแบบ ไม่ว่าจะเป็นไฟล์ SWF, HTML, GIF, JPEG, PNG, QuickTime เป็นต้น โดยท่ีเราสามารถ
ปรับคุณลักษณะของไฟล์งานเหล่านั้นได้ด้วยเช่นกัน ซึ่งเราจะมาศึกษาวิธีการแปลงงาน Flash หรือเรียกว่า “ท า
การพับลิช (publish)” ภายในบทนี้ 

 
สมรรถนะอาชีพประจ าหน่วย  



 

 

1. ท าการเผยแพร่ชิ้นงานในรูปแบบต่าง ๆ  
 

จุดประสงค์ท่ัวไป / บูรณาการเศรษฐกิจพอเพียง      
    1. มีความรู้ความเข้าใจและสามารถอธิบายเกี่ยวกับการพับลิชช้ินงานได้ 
 2. สามารถพับลิชช้ินงานเป็นไฟล์ แฟลชมูฟวี่ (flash movie) ได้ 

3. สามารถพับลิชช้ินงานเป็นไฟล์ HTML ได้ 
 

จุดประสงค์เชิงพฤติกรรม / บูรณาการเศรษฐกิจพอเพียง   
        1.   ท าการเผยแพร่ช้ินงานในรูปแบบ (flash movie)  และ HTML ได้ 
         2. เตรียมความพร้อมด้าน วัสดุ  อุปกรณ์สอดคล้องกับงานได้อย่างถูกต้อง 

    3.ปฏิบัติงานได้อย่างถูกต้อง และส าเร็จภายในเวลาท่ีก าหนดอย่างมีเหตุและผลตามหลักปรัชญาเศรษฐกิจ
พอเพียง    

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 
 
 

 

 
เนื้อหาสาระ 

การเผยแพร่และน าไปใช ้

 

เก่ียวกับการสร้างมูฟว่ี (Movie) 
1. การสร้างภาพเคล่ือนไหว แบบ Motion Tween จะท าให้ไฟล์เล็กกว่าแบบ Frame by Frame 
2. หลีกเล่ียงการน าภาพบิตแมพ มาสร้างเป็นภาพเคล่ือนไหว ควรน ามาใช้เป็นฉากหลังหรือภาพนิ่งเท่านั้น 
3. ควรใช้ซิมโบล แทนออบเจ็คท่ีมีปรากฏอยู่ในมูฟวี่ (ดูได้จากหน้าต่าง Library) 
4. หากจ าเป็นต้องน าภาพบิตแมพ มาใช้ ควรตัดภาพให้ขนาดเล็กเท่าท่ีจ าเป็นและบีบอัดคุณภาพลงก่อน 
5. หากต้องใช้เสียง ควรเลือกประเภท MP3 เนื่องจากเป็นไฟล์ท่ีมีขนาดเล็ก 

เก่ียวกับการ สร้างวัตถุ (Object) 
1. ควรรวมวัตถุ ให้เป็นกลุ่ม (Group) ให้มากท่ีสุด  
2. ควรแยกเลเยอร์ท่ีมีวัตถุเคล่ือนไหว และไม่เคล่ือนไหว ออกจากกัน  
3. การวาดเส้นทึบธรรมดา จะท าให้ไฟล์มีขนาดเล็กกว่าเส้นแบบจุด (dash) หรือ เส้นท่ีมีลวดลาย 
4. การวาดเส้นด้วยดินสอ (Pencil) จะท าให้ไฟล์มีขนาดเล็กกว่าการวาดเส้นด้วยแปรง (Brush) 
5.ภาพบิตแมพท่ีไม่มีความซับซ้อน ลดขนาดลงได้ด้วยการท า break apart 
6. ควรใช้ค าส่ัง Modify > Shape > Optimize เพื่อลดจ านวนเส้นท่ีประกอบกันเป็นรูปทรง 

เก่ียวกับการ สร้างตัวอักษรและข้อความ 
1. การใช้รูปแบบตัวอักษรท่ีหลากหลาย ท าให้ไฟล์มีขนาดใหญ่ 
2. การฝังฟอนต์ (Embedded) ไปกับมูฟวี่ ท าให้ไฟล์มีขนดใหญ่ ควรใช้เท่าท่ีจ าเป็น 

เก่ียวกับการใช้ สี 
1. หากรูปภาพหรือวัตถุ ทีมีความคล้ายกัน ควรสร้างจากซิมโบล แล้วค่อยน ามาปรับขนาดหรือสี 
2. ควรใช้ฟิลเตอร์เท่าท่ีจ าเป็น 

หมายเหตุ : ควรตรวจสอบไฟล์ หรือวัตถุต่างๆ ใน Library ท่ีไม่ได้ใช้งานและลบท้ิง 

เมื่อท าแอนิเมช่ันเสร็จตามต้องการแล้ว การส่งออกไฟล์เพื่อน าเสนอ ท าได้โดย 
คลิกเมนู File > Pubblish Settings... (หมายเลข 14) 



 

 

 

 
คลิกท่ีแท็บ Formats แล้วคลิกเลือก Windows Projector (.exe) (หมายเลข 15) 
สามารถเลือก Path ส าหรับการส่งออกได้ (หมายเลข 16) 
ท าการส่งออกโดยคลิก Publish (หมายเลข 17) 

 

การ Publish 

เมื่อสร้างงานตามทีต้องการแล้ว ข้ันตอนสุดท้าย คือการน าผลงานไปใช้ หรือการส่งออก โดยสามารถเลือก
รูปแบบ 



 

 

การส่งออกเป็นไฟล์ชนิดต่างๆ ตามวัตถุประสงค์การใช้งานซึ่งท าได้ ดังนี้ 

ขั้นตอนการ Publish 
1. คลิกเมนู File > Publish Settings... 

 

  2. ท่ีหน้าต่าง Publish Settings ก าหนดรูปแบบไฟล์ ก าหนดช่ือไฟล์ และก าหนดสถานท่ี 
  หรือ Path ท่ีต้องการส่งออก 

 

1. การก าหนดชนิดไฟล์ท่ีต้องการส่งออก 
ท าได้โดย คลิกเครื่องหมายถูก หน้าชนิดของไฟล์ท่ีต้องการ (กรอบหมายเลข 1) 
2. เมื่อคลิกในข้อ 2.1 แล้ว จะปรากฏแท็บคุณสมบัตินั้นๆ ( ดังกรอบหมายเลข 2) 
3. หากต้องการเปล่ียนช่ือไฟล์ สามารถเปล่ียนได้ในช่องกรอบหมายเลข 3 



 

 

4. การเลือกสถานท่ี หรือ Path ในการบันทึกไฟล์ ท าได้โดยคลิกสัญลักษณ์โฟลเดอร์ ในหมายเลข 4 

ในการก าหนดคุณสมบัติการส่งออกของ ไฟล์แต่ละชนิด ท าได้โดยคลิกแท็บชนิดนั้นๆ 
เช่น การก าหนดค่าการส่งออกภาพเคล่ือนไหวของ Flash ซึ่งจะได้ไฟล์ .swf เมื่อคลิกแท็บ Flash จะปรากฏ
หน้าต่างส าหรับ 
การตั้งค่าคุณสมบัติ ดังภาพที่ 3 แล้วก าหนดค่าตามต้องการ 

 

ในกรณีต้องการส่งออกเป็นรูปภาพ ชนิด .jpg ท าได้โดยคลิกท่ีแท็ป JPEG 
ซึ่งจะได้หน้าต่างส าหรับการตั้งค่าคุณสมบัติดังภาพ แล้วก าหนดค่าตามต้องการ 



 

 

 

  ในกรณีต้องการส่งออกเป็นรูปภาพ ชนิด .gif ท าได้โดยคลิกท่ีแท็ป GIF 
   ซึ่งจะได้หน้าต่างส าหรับการตั้งค่าคุณสมบัติดังภาพ แล้วก าหนดค่าตามต้องการ 
 

  

 
หรือหากต้อง การส่งออกเป็นไฟล์เว็บเพจ ท าได้โดยคลิกท่ีแท็ป HTML 
ซึ่งจะได้หน้าต่างส าหรับการตั้งค่าคุณสมบัติแล้วก าหนดค่าตามต้องการ 



 

 

 

 
  เมื่อก าหนดค่าต่างๆ ตามต้องการแล้ว คลิกท่ีปุ่ม Publish เพื่อท าการส่งออกไฟล์ และน าไปใช้ต่อไป 

 

 

การ Export ไฟล์เพือ่น าไปใช้กับเอกสารอื่นๆ 
การส่งออกไฟล์เพื่อน าไปใช้ นอกจากจะส่งออกในแบบของการ Publish แล้ว 
ยังสามารถส่งออกแบบเด่ียวๆ ตามแต่ชนิดของการใช้งานตามต้องการ ดังนี้ 

ขั้นตอนการส่ง ออกภาพเดียว 
1. คลิกเมนู File > Export > Export Image... (หมายเลข 1) 



 

 

 

2. เลือกสถานท่ีบันทึก และพิมพ์ชื่อไฟล์ท่ีต้องการบันทึก (หมายเลข 2)  
เลือกชนิดของไฟล์ (หมายเลข 3) แล้วคลิก Save (หมายเลข 4) 

 

 



 

 

3. ก าหนดคุณสมบัติของไฟล์ โดยต้ังค่าในกรอบหมายเลข 5 
เมื่อก าหนดค่าตามต้องการแล้ว คลิก OK (หมายเลข 6) เพื่อส่งออกไฟล์ 

  

  

ขั้นตอนการส่งออกมูฟวี ่

1. คลิกเมนู File > Export > Export Movie... (หมายเลข 7) 

 

2. เลือกสถานท่ีบันทึก และพิมพ์ชื่อไฟล์ท่ีต้องการบันทึก (หมายเลข 8)  
เลือกชนิดของไฟล์ (หมายเลข 9) ซึ่งชนิดของไฟล์หากต้องการเป็นไฟล์ Flash ต้องเลือกเป็น .swf 
แล้วคลิก Save (หมายเลข 10) 
          



 

 

 

 
หมายเหตุ : ในกรณีท่ีต้องการไฟล์ชนิดอื่นๆ สามารถเลือกชนิดไฟล์ โดยการคลิกท่ีปุ่มหมายเลข 9 
แล้วเลือกชนิดไฟล์ ซึ่งมีหลายรูปแบบ ดังภาพหมายเลข 11 

 

 แหล่งข้อมูล : http://202.143.142.151/flash/ 
 

 
 
 
 
 
 
 
 

http://202.143.142.151/flash/


 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

กิจกรรมการเรียนการสอนหรือการเรียนรู้ 
ข้ันตอนการสอนหรือกิจกรรมของครู ข้ันตอนการเรียนรู้หรือกิจกรรมของนักเรยีน 

1.  ข้ันน าเข้าสู่บทเรียน  (15 นาท ี) 
1. บอกวัตถุประสงค์การเรียน  
2. กฏเกณฑ์การเรียน คะแนน วิธีการวัดผล 
3. สอบเก็บคะแนนบทท่ี 10 
4. น าเข้าสู่บทเรียน 

  

2.  ขั้นให้ความรู้ (75 นาท)ี 

     1. สอนการ เผยแพร่และการน าไปใช้ 

2. ครูให้เรียนจาก CAI  
3. ลองปฏิบัติตามจาก CAI  
4. ท าการสรุปส่วนประกอบ เครื่องมือ ร่วมกัน

ในช้ันเรียนโดยการถาม-ตอบ 
 

3. ขั้นประยุกต์ใช้ ( 105 นาที ) 

1. ผู้สอนให้ผู้เรียนท าแบบฝึกหัด   

1.  ข้ันน าเข้าสู่บทเรียน  (15 นาท ี) 
      1. ฟังวัตถุประสงค์การเรียน  
      2.  ฟังกฏระเบียบในการเรียน 
      3.  สอบปฏิบัติกับเครื่องคอมพิวเตอร์ 
      4.  ฟังและตอบค าถาม 
 

2.  ข้ันให้ความรู้ (75 นาท ี) 
1.  ฟัง และดูตัวอย่าง  
2.  เรียนจาก CAI  
3.  ปฏิบัติตามจาก CAI  
4. ท าการสรุปส่วนประกอบ เครื่องมือ ร่วมกัน

ในช้ันเรียนโดยการถาม-ตอบ 
 
 
3.  ขั้นประยุกต์ใช้ ( 105 นาท ี) 

1. ผู้เรียนท าแบบฝึกหัด    



 

 

2.  น าส่ิงท่ีเรียนไปใช้ในการประกอบช้ินงาน 
 

4.  ขั้นสรุปและประเมินผล ( 30 นาที ) 
1. ผู้สอนและผู้เรียนร่วมกันสรุปเนื้อหาท่ีได้

เรียนให้มีความเข้าใจในทิศทางเดียวกัน 
2. สอบเก็บคะแนน 

 
 

 
 

2. น าส่ิงท่ีเรียนไปท าการสร้างช้ินงาน 
 
4.  ข้ันสรุปและประเมินผล ( 30 นาที ) 

1. ผู้สอนและผู้เรียนร่วมกันสรุปเนื้อหาท่ีได้เรียน
เพื่อให้มีความเข้าใจในทิศทางเดียวกัน 

2. ลองฝึกทักษะเพื่อน ามาสอบปฏิบัติ 
 
 
 
 
 
 
 
 
 
 

 

งานที่มอบหมายหรือกิจกรรมการวัดผลและประเมินผล 

         ก่อนเรียน  
             1.   การถาม-ตอบ ก่อนเรียน    
 

         ขณะเรียน 
   สืบค้นข้อมูลจาก Internet เพื่อเป็นเนื้อหาเพิ่มเติมขณะเรียน 
 

 หลังเรียน 
1.  ช้ินงานนักศึกษาท่ีครูให้ค้นหา 
2. อ่านหนังสือสอบในสัปดาห์ถัดไป 
 

ค าถาม 
          - 

ผลงาน/ชิ้นงาน/ความส าเร็จของผู้เรียน 
1.  งานท่ีปฏิบัติกับเครื่องคอมพิวเตอร์ 

 



 

 

สมรรถนะที่พึงประสงค ์
ผู้เรียนสร้างความเข้าใจเกี่ยวกับ    
1. วิเคราะห์และตีความหมาย 
2. ต้ังค าถาม 
3. อภิปรายแสดงความคิดเห็นระดมสมอง 
4. การประยุกต์ความรู้สู่งานอาชีพ 

 

สมรรถนะการสร้างคา่นิยม 
ปลูกฝังคุณธรรม จริยธรรม 
 
 
 
 
 
 
 
 
 

 

สมรรถนะการปฏิบตัิงานอาชีพ 

1.     ใช้ในการประกอบวิชาชีพด้านการออกแบบ    
 

สมรรถนะการขยายผล 
- 

สื่อการเรียนการสอน/การเรยีนรู ้
 
 สื่อสิ่งพิมพ์ 
                ตัวอย่าง งานต่าง ๆ ใน Internet  
  

 
 

 
 สื่อโสตทัศน์ (ถ้ามี) 

1. CAI 



 

 

 
    
สื่อของจริง 
 

1.    ส่ือนักศึกษาท่ีครูให้ท าในภาคเรียนท่ีแล้ว , Internet, E-learning, E- books, Website 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

แหล่งการเรียนรู ้
 
     ในสถานศึกษา 

1. ห้องสมุดวิทยาลัยเทคนิคพัทยา 
2. ห้องปฏิบัติการ  732 
3. มือถือนักศึกษา  (กรณี Net วิทยาลัยไม่สามารถใช้งานได้) 
 

    นอกสถานศึกษา 

                           - 
 

การบูรณาการ/ความสมัพันธ์กับวิชาอ่ืน 
1. บูรณาการกับวิชาชีวิตและวัฒนธรรมไทย   ด้านการพูด  การอ่าน  การเขียน และการฝึกปฏิบัติตนทาง

สังคมด้านการเตรียมความพร้อม  ความรับผิดชอบ และความสนใจใฝ่รู้ 



 

 

2. บูรณาการกับวิชากีฬาเพื่อพัฒนาสุขภาพและบุคลิกภาพ  ด้านบุคลิกภาพในการน าเสนอหน้าช้ันเรียน 
3. บูรณาการกับวิชาหลักเศรษฐศาสตร์ ด้านการเลือกใช้ทรัพยากรอย่างประหยัด 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

การประเมินผลการเรียนรู ้

 หลักการประเมินผลการเรียนรู ้
 

 ก่อนเรียน 
1.  สืบค้นตัวอย่างประกอบ 

 
 
            ขณะเรยีน 

1. ความสนใจในการเรียนรู้ การค้นคว้า การมีส่วนร่วมในกิจกรรม 
2. การซักถามและการตอบค าถาม 

     
 



 

 

            หลังเรียน 

     สอบหลังเรียน 

 
ผลงาน/ชิ้นงาน/ผลส าเร็จของผู้เรียน  

1.   ช้ินงานท่ีมอบหมายให้นักศึกษาปฏิบัติกับเครื่องคอมพิวเตอร์  
 
รายละเอียดการประเมินผลการเรียนรู ้

1.  สอบปฏิบัติกับคอมพิวเตอร์ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

แบบประเมินผลการน าเสนอผลงาน 

ช่ือกลุ่ม……………………………………………ช้ัน………………………ห้อง........................... 
รายช่ือสมาชิก       1……………………………………เลขท่ี…….    2…………………………………เลขท่ี……. 

                        3……………………………………เลขท่ี…….    4……………………………………เลขท่ี……. 

ท่ี รายการประเมิน 
คะแนน 

ข้อคิดเห็น 
3 2 1 

1 เนื้อหาสาระครอบคลุมชัดเจน (ความรู้เกี่ยวกับเนื้อหา ความ
ถูกต้อง  ปฏิภาณในการตอบ และการแก้ไขปัญหาเฉพาะหน้า) 

    

2 รูปแบบการน าเสนอ     
3 การมีส่วนร่วมของสมาชิกในกลุ่ม     



 

 

4 บุคลิกลักษณะ  กิริยา  ท่าทางในการพูด  น้ าเสียง  ซึ่งท าให้
ผู้ฟังมีความสนใจ 

    

รวม     
 

            ผู้ประเมิน………………………………………………… 
เกณฑ์การให้คะแนน 
1.  เนื้อหาสาระครอบคลุมชัดเจนถูกต้อง 
 3  คะแนน    =  มีสาระส าคัญครบถ้วนถูกต้อง  ตรงตามจุดประสงค์ 
 2  คะแนน    =  สาระส าคัญไม่ครบถ้วน  แต่ตรงตามจุดประสงค์ 
 1  คะแนน    =  สาระส าคัญไม่ถูกต้อง ไม่ตรงตามจุดประสงค์ 
2.  รูปแบบการน าเสนอ 

3  คะแนน     =  มีรูปแบบการน าเสนอท่ีเหมาะสม  มีการใช้เทคนิคท่ีแปลกใหม่  ใช้ส่ือและ
เทคโนโลยีประกอบการ น าเสนอท่ีน่าสนใจ  น าวัสดุในท้องถิ่นมาประยุกต์ใช้อย่างคุ้มค่าและ
ประหยัด 

1. คะแนน    =  มีเทคนิคการน าเสนอท่ีแปลกใหม่  ใช้ส่ือและเทคโนโลยีประกอบการน าเสนอท่ี
น่าสน ใจ  แต่ขาดการประยุกต์ใช้ วัสดุในท้องถิ่น         

           1  คะแนน     =  เทคนิคการน าเสนอไม่เหมาะสม และไม่น่าสนใจ 
3.  การมีส่วนร่วมของสมาชิกในกลุ่ม 
 3  คะแนน     =  สมาชิกทุกคนมีบทบาทและมีส่วนร่วมกิจกรรมกลุ่ม 
 2  คะแนน     =  สมาชิกส่วนใหญ่มีบทบาทและมีส่วนร่วมกิจกรรมกลุ่ม 
 1  คะแนน     =  สมาชิกส่วนน้อยมีบทบาทและมีส่วนร่วมกิจกรรมกลุ่ม 
4.  ความสนใจของผู้ฟัง 
 3  คะแนน     =  ผู้ฟังมากกว่าร้อยละ 90  สนใจ และให้ความร่วมมือ 
 2  คะแนน     =  ผู้ฟังร้อยละ 70-90  สนใจ และให้ความร่วมมือ 
 1  คะแนน     =  ผู้ฟังน้อยกว่าร้อยละ 70  สนใจ และให้ความร่วมมือ 

แบบประเมินกระบวนการท างานกลุ่ม 

ช่ือกลุ่ม……………………………………………ช้ัน………………………ห้อง........................... 
รายช่ือสมาชิก       1……………………………………เลขท่ี…….    2…………………………………เลขท่ี……. 

                        3……………………………………เลขท่ี…….    4……………………………………เลขท่ี……. 

ท่ี รายการประเมิน 
คะแนน 

ข้อคิดเห็น 
3 2 1 

1 การก าหนดเป้าหมายร่วมกัน     
2 การแบ่งหน้าท่ีรับผิดชอบและการเตรียมความ     



 

 

พร้อม 
3 การปฏิบัติหน้าท่ีท่ีได้รับมอบหมาย     
4 การประเมินผลและปรับปรุงงาน     

รวม     
 

ผู้ประเมิน………………………………………………… 
วันท่ี…………เดือน……………………..พ.ศ…………... 

เกณฑ์การให้คะแนน 

1.  การก าหนดเป้าหมายร่วมกัน 
 3  คะแนน  =  สมาชิกทุกคนมีส่วนร่วมในการก าหนดเป้าหมายการท างานอย่างชัดเจน 
 2  คะแนน  =  สมาชิกส่วนใหญ่มีส่วนร่วมในการก าหนดเป้าหมายในการท างาน 

1  คะแนน  =  สมาชิกส่วนน้อยมีส่วนร่วมในการก าหนดเป้าหมายในการท างาน 
2.  การมอบหมายหน้าท่ีรับผิดชอบและการเตรียมความพร้อม 

3  คะแนน  =  กระจายงานได้ท่ัวถึง  และตรงตามความสามารถของสมาชิกทุกคน   มีการ
จัดเตรียมสถานท่ี  ส่ือ /  
                     อุปกรณ์ไว้อย่างพร้อมเพรียง 

 2  คะแนน  =  กระจายงานได้ท่ัวถึง  แต่ไม่ตรงตามความสามารถ  และมีส่ือ / อุปกรณ์ไว้อย่าง
พร้อมเพรียง แต่ขาด 
                                     การจัดเตรียมสถานท่ี 
 1  คะแนน  =  กระจายงานไม่ท่ัวถึงและมีส่ือ / อุปกรณ์ไม่เพียงพอ 
3.  การปฏิบัติหน้าท่ีท่ีได้รับมอบหมาย 
 3  คะแนน  =  ท างานได้ส าเร็จตามเป้าหมาย และตามเวลาท่ีก าหนด 
 2  คะแนน  =  ท างานได้ส าเร็จตามเป้าหมาย แต่ช้ากว่าเวลาท่ีก าหนด 
 1  คะแนน  =  ท างานไม่ส าเร็จตามเป้าหมาย 
4.  การประเมินผลและปรับปรุงงาน 
 3  คะแนน  =  สมาชิกทุกคนร่วมปรึกษาหารือ  ติดตาม  ตรวจสอบ  และปรับปรุงงานเป็นระยะ 
 

บันทึกหลังการจัดการเรียนรู้ 

รหัสวิชา  3204-2102  เทคนิคการสร้างภาพเคลื่อนไหวคอมพิวเตอร์   
วันที่ …………………….. สัปดาห์ที่…...... 

.คอมพิวเตอร์ธุรกิจ คอมพิวเตอร์ธุรกิจ/2 | ปวส.1 | 2558  
ครูผู้สอน 2003002 นางสาวภคมน หวังวัฒนากูล จ านวน 20 คน  

 
หัวข้อเร่ือง/เนื้อหาสาระ : 

 



 

 

  
 

กิจกรรม/วิธีการสอน 
 

  
 

  
 

 
สื่อการเรียนรู้/แหล่งการเรียนรู้ 

 
 
 
สอดแทรกคุณธรรมจริยธรรม  

 
  

 
 

 
การวัดและประเมินผลหลังการสอน  

 
  

 
 

 
สมรรถนะท่ีนักเรียนได้  

 
  

 
 

 
ผลการใช้และปรับปรุงแผนการสอน  

 
  

 
 

  

ปัญหาที่น าไปสู่การวิจัย  
 
 

  
 

 
 
 



 

 

แบบประเมินผล 

วันที่ .............. เดือน ............................... พ.ศ. ............... 

ล าดับ
ที่ ชื่อ - นามสกุล 

ผลการประเมิน 

รวม ผลงาน การมีส่วน
ร่วม 

ความรับผิดชอบ 

  1 2 3 4 1 2 3 1 2 3 10 

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

เกณฑ์การให้คะแนน 
 ดีมาก = 4            ดี = 3  ปานกลาง = 2   ต้องปรับปรุง = 1 

 

แบบประเมินคุณธรรมจรยิธรรม 

ค าชี้แจง  ให้ขดีเครื่องหมายถูก ในช่องพฤติกรรมของนักเรียนเพ่ือประเมินคุณธรรม
จริยธรรม 

เกณฑ์การตัดสิน 
                                           4          คะแนน          หมายถึง          พฤติกรรมดีมาก 

                                       3          คะแนน          หมายถึง          พฤติกรรมดี 
                                       2          คะแนน          หมายถึง          พฤติกรรมพอใช้ 
                                       1          คะแนน          หมายถึง          พฤติกรรมต้องปรับปรุง 



 

 

 
 
 

 
 

เลข 

ที ่

 

ชื่อ – สกุล 

ผู้รับการ 

ประเมิน 

 

                             พฤติกรรมของนักเรียน 

ความมีวินัย ความ
รับผิดชอบ 

มนุษย์
สัมพันธ์ 

ความอดทน ความรอบ
ปลอดภัย 

 

รวม 

4 3 2 1 4 3 2 1 4 3 2 1 4 3 2 1 4 3 2 1 20 

1                       

2                       

3                       

4                       

5                       

6                       

7                       

8                       

9                       

10                       

11                       

12                       

13                       

14                       

15                       

16                       

17                       

18                       

19                       

20                       

21                       

22                       

23                       

24                       

25                       

26                       

27                       

28                       

29                       

30                       

 

                                                                                      ผู้ประเมิน……………………………                                                                                                                            



 

 

                                                                                                 (…………………………..) 
 

 
 

แบบฝึกหัด 
อธิบาย (หมายถึง การให้รายละเอียดเพิ่มเติม ขยายความ ถ้ามีตัวอย่างให้ยกตัวอย่าง  ประกอบ) ตอบ

แบบสั้น 
1. กระบวนการพับลิชเอกสาร Flash ประกอบด้วยกี่ข้ันตอน อะไรบ้าง 

ตอบ   2 ขั้นตอน  เริ่มจากการเลือกประเภทของไฟล์ พร้อมกับต้ังค่าต่าง ๆ ด้วยค าส่ัง Publish Settings 
จากนั้นจึงพับลิชเอกสาร โดยใช้ค าส่ัง Publish ซึ่งสามารถสร้างไฟล์ในฟอร์แมตต่างๆ ได้ 
 
2. การต้ังค่าใน Publish Settings สามารถท าได้อย่างไร 

ตอบ 1. เลือกค าส่ัง File > Publish Settings… 
 2. ท่ีไดอะล็อกบ็อกซ์ Publish Settings ให้ก าหนดออปช่ันต่าง ๆ ในแต่ละแท็บ 
 3. คลิกปุ่ม OK เพื่อจบการตั้งค่า หรือคลิกปุ่ม Publish ไฟล์ทันที 
3. การเลือกเวอร์ชันของ Flash Player ที่จะใช้เล่นมูฟว่ี ถ้าก าหนดไม่เหมาะสมจะส่งผลอย่างไร และควรแก้ไขอย่างไร 

ตอบ ถ้าก าหนดไม่เหมาะสมอาจท าให้มูฟวี ่ไม่แสดง เช่น มูฟวี ่มีการใช้คุณสม บัติใหม่ ๆ ของ
เวอร์ชัน 8 แต่ผู้ชมยังคงใช้เวอร์ชัน 7 อยู่ อาจท าให้ไม่สามารถชมมูฟวี่ได้  วิธีแก้ไขคือ ควรเตรียมลิงค์
ส าหรับให้ผู้ชมคลิกเพื่อไปดาวน์โหลดโปรแกรม Flash Player เวอร์ชันใหม่มา หรือเลือกพับลิชไฟล์
ไปเป็นเวอร์ชัน 7 
4. เราสามารถน าไฟล์ Flash ไปใช้งานในรูปแบบ GIF ได้อย่างไร 
ตอบ เลือกค าส่ังออปช่ัน GIF ส าหรับให้ก าหนดคุณสมบัติของไฟล์ 
5. เราสามารถน าไฟล์ Flash ไปใช้งานในรูปแบบ PNG ได้อย่างไร 

ตอบ เลือกค าส่ังออปช่ัน PNG และก าหนดค่าคุณสมบัติของไฟล์ 
6. อธิบายความหมายของการก าหนดค่าคุณสมบัติที่ต้องการแบบ Debugging Permitted ว่ามีลักษณะอย่างไร 

ตอบ เปิดให้โปรแกรมส าหรับช่วยตรวจหาและแก้ไขความผิดพลาดของค า ส่ัง ActionScript 
(Debugger) ท างาน และยอมให้มีการเรียกใช้จากระยะไกลได้เมื่อเลือกออบช่ันนี้ หากต้องการป้องกัน
ไม่ให้คนอื่นเรียกใช้ Debugger ได้ก็ให้ก าหนดรหัสผ่านลงในช่อง Password 
7. อธิบายความหมายของการก าหนดค่าคุณสมบัติที่ต้องการแบบ Generate Size Report ว่ามีลักษณะอย่างไร 

ตอบ เลือกเพื่อสร้างไฟล์ข้อความ (txt) ในช่ือเดียวกับไฟล์มูฟวี่ (swf) โดยไฟล์นี้จะให้รายละเอียด
เกี่ยวกับขนาดของแต่ละส่วนประกอบของมูฟวี่ในหน่วยเป็นไบต์ (byte) เพื่อใช้ในการวิเคราะห์ส าหรับช่วย
ปรับลดขนาดมูฟวี่ภายหลัง 
8. ไฟล์ JPEG มีคุณสมบัติแตกต่างจาก GIF อย่างไร จงอธิบาย 

ตอบ ไฟล์ JPEG มีคุณสมบัติแตกต่างจาก GIF คือ สามารถปรับระดับการบีบอัดข้อมูลได้ ซึ่งจะให้ได้
คุณภาพท่ีแตกต่างกันไป คือ ยิ่งบีบอัดมากขนาดไฟล์ก็จะเล็กลง แต่คุณภาพของภาพก็ยิ่งด้อยลงด้วย 



 

 

โดยท่ัวไปไฟล์ GIF จะเหมาะส าหรับภาพท่ีเป็นลายเส้นหรือรูปวาดท่ีใช้สีเรียบส่วน JPEG เหมาะส าหรับ
ภาพที่มีการใช้สีเกรเดียนท์มาก ๆ หรือภาพถ่าย นอกจากนี้ JPEG ยังไม่สามารถท าภาพเคล่ือนไหวได้ 
9. แท็บ PNG เหมาะส าหรับการน าเสนอผลงานในรูปแบบใด 

ตอบ ท าให้ภาพมีความโปร่งใส  และสามารถก าหนดค่าความละเอียดของสีท่ีปรากฏบนภาพ ก าหนด
แสงภาพให้ละเอียดยิ่งขึ้น 
10. อธิบายวิธีเอ็กซ์พอร์ตทั้งมูฟว่ี สามารถท าได้อย่างไร 

ตอบ 1. เปิดมูฟวี่ที่ต้องการเอ็กซ์พอร์ต แล้วเลือกค าส่ัง File > Export > Export Movie… 
 2. ต้ังช่ือและเลือกชนิดของไฟล์แล้วคลิกปุ่ม Save 
 3. ส าหรับไฟล์บางชนิดจะมีออปช่ันเพิ่มเติมให้เราก าหนดด้วย 
 
ตอนที่  2  : อธิบายค าศัพท์ (หมายถึง การแปลค าศัพท์ ขยายความ อธิบายเพิ่มเติม ถ้ามีตัวอย่างให้

ยกตัวอย่างประกอบ) ตอบแบบสั้น 
1. Debugger 
ตอบ การแก้ไขความผิดพลาดของค าส่ัง ActionScript 
2. Paused at Start 
ตอบ ก าหนดไม่ให้มูฟวี่เริ่มเล่นโยทันทีโดยอัตโนมัติ 
3. Auto Low 
ตอบ เน้นท่ีความเร็วเป็นอย่างแรก 
4. Auto High 
ตอบ เน้นท่ีความเร็วและคุณภาพของภาพ 
5. Opaque Windowless 
ตอบ ให้พื้นหลังของบริเวณท่ีใช้แสดงมูฟวี่โปร่งใส ซึ่งจะท าให้มองเห็นส่ิงท่ีอยู่ด้านหลัง 
6. Interlace 
ตอบ ก าหนดให้ภาพค่อยๆ ปรากฏชัดขึ้นขณะท่ีเบราเซอร์ก าลังโหลดไฟล์ 

7. Alpha Transparent 
ตอบ มูฟวี่โปร่งแสง และสามารถมองเห็นภาพจากส่วนอื่นท่ีอยู่ด้านหลังมูฟวี่ได้ 
8. Loop Continuously 
ตอบ การเล่นแบบวนไม่รู้จบ 
9. Animated 
ตอบ ภาพเคล่ือนไหว 
10. Dither Solids 
ตอบ ก าหนดให้ใช้เทคนิค Dither กับสีเรียบเช่นเดียวกับสีเกรเดียนท์ 
 


