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1 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

 

หน่วยที่ 2   ARDUINO IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C 

   
  สำระส ำคัญ 
 

              ซอฟต์แวร์ท่ีใช้ในกำรพัฒนำงำนส ำหรับบอร์ด Arduino นั่นคือโปรแกรมท่ีเรียกว่ำ Arduino IDE ในกำร
เขียนโปรแกรมและคอมไพล์ลงบอร์ด IDE ย่อมำจำก (Integrated Development Environment) คือ ส่วนเสริมของ
ระบบกำรพัฒนำหรือตัวช่วยต่ำงๆท่ีจะคอยช่วยเหลือ Developer หรือช่วยเหลือคนท่ีพัฒนำ Application เพื่อเสริมให้
เกิดควำมรวดเร็ว ถูกต้อง แม่นย ำ ตรวจสอบระบบท่ีจัดท ำได้ ท ำให้กำรพัฒนำงำนต่ำงๆเร็วมำกขึ้น  
 

    เนื้อหำสำระกำรเรียนรู้ 
 
2.1 กำรติดต้ังซอฟต์แวร์ Arduino IDE  
2.2 ลักษณะโดยท่ัวไปของโปรแกรม Arduino IDE 
2.3 เมนูบำร์แสดงรำยกำรของค ำส่ัง 
2.4 กำรทดสอบกำรท ำงำนบอร์ด Arduino เบ้ืองต้น 

 

    จุดประสงค์กำรเรียนรู้ 
 

        จุดประสงค์ทั่วไป 
    
   1. เพื่อให้มีควำมรู้ควำมเข้ำใจเกี่ยวกับกำรติดต้ังซอฟต์แวร์ Arduino IDE 
   2. เพื่อให้สำมำรถน ำควำมรู้ไปประยุกต์ใช้ในกำรเขียนโปรแกรม Arduino IDE     
   3. เพื่อให้ตระหนักถึงควำมส ำคัญของกำรทดสอบกำรท ำงำนบอร์ด Arduino เบ้ืองต้น 

 

        จุดประสงค์เชิงพฤติกรรม 
  
1. อธิบำยกำรติดต้ังซอฟต์แวร์ Arduino IDE ได้ 
2. อธิบำยลักษณะโดยท่ัวไปของโปรแกรม Arduino IDE ได้ 
3. บอกวิธีกำรใช้เมนูบำร์แสดงรำยกำรของค ำส่ังได้ 
4. ทดสอบกำรท ำงำนบอร์ด Arduino เบ้ืองต้นได้ 
5. ทดสอบกำรท ำงำนซอฟต์แวร์ Arduino IDE เบ้ืองต้นได้ 
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2 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  
 

*********************************************************************************** * *
* 

 
 

เร่ือง   Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                               ใช้เวลำ 20 นำที 
วิชำ   ไมโครคอนโทรลเลอร์เบื้องต้น               รหัสวิชำ (2127-2107)                                                                          
ระดับชั้น  ประกำศนียบัตรวิชำชีพ (ปวช.)                                            สำขำวิชำ เมคคำทรอนิกส์ 
 
ค ำช้ีแจง    1. แบบทดสอบมีทั้งหมด 10 ข้อ (10 คะแนน)  
        2. ให้ผู้เรียนเลือกค ำตอบที่ถูกที่สุดแล้วกำเคร่ืองหมำยกำกบำท () ลงในกระดำษค ำตอบ 
 
1. กำรติดต้ัง Arduino IDE ต้องไป Download ท่ีใด 
       ก.    Arduinotronic.cc  
       ข.    Arduinoall.cc  
       ค.    Arduinothailand.cc 
       ง.    Arduino.cc 
2. เมื่อพบเครื่องหมำยตกใจสีเหลืองท่ี Device Manager ต้องท ำอย่ำงไร 
       ก.   แจ้งบริษัทผู้ผลิต 
       ข.   ไม่สำมำรถท ำอะไรได้อีกแล้ว 
       ค.   Update Driver Software 
       ง.    Update Window   
3. โปรแกรม Arduino IDE โดย IDE ย่อมำจำก 
        ก.   Integral development environment 
        ข.   Integer development environment 
        ค.   Intent development environment 
        ง.    Integrated development environment 
4. เมนู File ใน Arduino จะเรียกโปรแกรมท่ีสร้ำงขึ้นใหม่ว่ำอะไร 
        ก.   Notebook  
        ข.   Facebook                      
        ค.   Sketchbook                               
        ง.    Handbook 
 

 

แบบทดสอบก่อนเรียน หน่วยที่ 2 
เร่ือง Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C 
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3 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

5. สัญลักษณ์ของเครื่องหมำย Comment ตรงกับข้อใด 
       ก.   --  
       ข.   //                         
       ค.   **                         
       ง.   ++ 
6. เมนู File > Example  ใช้ส ำหรับ 
       ก.   ใช้ในกำรเลือกเปิดไฟล์ Sketch ตัวอย่ำงท่ีบรรจุและรวบรวมไว้ 
       ข.   ใช้ก ำหนดค่ำกำรท ำงำนของโปรแกรม 
       ค.   ใช้เปิดไฟล์ Sketch ล่ำสุดท่ีเปิดใช้งำนเสมอ 
       ง.   ใช้สร้ำงไฟล์ Sketch ตัวใหม่เพื่อเริ่มเขียนโปรแกรมใหม่ 
7. กำรตรวจสอบพอร์ตท่ีต่อใช้งำน ถูกต้องหรือไม่ต้องตรวจสอบท่ีใด 
 ก.  tool > serial Monitor  
 ข.  tool > bord 
 ค.  tool > Port   
        ง.  tool > serial Port 
8. เมนู Tools > Board ใช้ส ำหรับ 
        ก.   จัดรูปแบบของโค้ดโปรแกรมให้สวยงำม 
        ข.   เลือกหมำยเลขพอร์ตของคอมพิวเตอร์ท่ีต่อกับฮำร์ดแวร์       
        ค.   เลือกฮำร์ดแวร์ของบอร์ไมโครคอนโทรลเลอร์ Arduino  
        ง.   ส่ังบีบอัดไฟล์ โปรแกรมท้ังโฟลเดอร์หลักและโฟลเดอร์ย่อ  
9. ค ำส่ังใดเป็นค ำสังหน่วงเวลำ 
        ก.   delay 
        ข.   pin mode  
        ค.   digital Write         
        ง.   output 
10. บอดเรต (baud rate) คือ 
 ก.   อัตรำเร็วในกำรรับส่งข้อมูลทีต้องก ำหนดค่ำ 
        ข.   หน่วยควำมจ ำส ำหรับเก็บโปรแกรมแบบแฟลช (ROM) 
 ค.   พอร์ตอินพุตเอำต์พุตให้ใช้งำนจ ำนวน 23 ขำ 
 ง.   ตัวฮำร์ดแวร์ของ Arduino 

 



 

หน่วยที่ 2 Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                                             เรียบเรียงโดยครูทันพงษ์  ภู่รักษ ์
 

4 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  
 

                            
  
 หลังจำกรู้จักกับ Arduino จำกบทท่ี 1 แล้วล ำดับต่อไปเป็นกำรอธิบำยถึงซอฟต์แวร์ท่ีใช้ในกำรพัฒนำงำน
ส ำหรับบอร์ด Arduino นั่นคือโปรแกรมท่ีเรียกว่ำ Arduino IDE ในกำรเขียนโปรแกรมและคอมไพล์ลงบอร์ด โดย
ขนำดของโปรแกรม Arduino โดยปกติแล้วจะใหญ่กว่ำโค้ด AVR ปกติเนื่องจำกโค้ด AVR เป็นกำรเข้ำถึงจำก
รีจิสเตอร์โดยตรง แต่โค้ด Arduino เข้ำถึงผ่ำนฟังก์ช่ัน เพื่อให้สำมำรถเขียนโค้ดได้ง่ำยมำกกว่ำกำรเขียนโค้ดแบบ 
AVR หรือเวอร์ช่ันอื่นๆ ของ Arduino 
 IDE ย่อมำจำก (Integrated Development Environment) คือ ส่วนเสริมของระบบกำรพัฒนำหรือตัว
ช่วยต่ำงๆท่ีจะคอยช่วยเหลือ Developer หรือช่วยเหลือคนท่ีพัฒนำ Application เพื่อเสริมให้เกิดควำมรวดเร็ว 
ถูกต้อง แม่นย ำ ตรวจสอบระบบท่ีจัดท ำได้ ท ำให้กำรพัฒนำงำนต่ำงๆเร็วมำกขึ้น  
 
 2.1 กำรติดต้ังซอฟต์แวร์ Arduino IDE 
 Download โปรแกรม Arduino IDE ฟรีท่ีเวป Arduino.cc/en/Main/Software และกด Click 
ท่ี Download เพื่อเข้ำสู่ Download Page  
 

 
รูปที่ 2.1 หน้ำต่ำง Download โปรแกรม Arduino IDE  

 
 เลือกระบบปฏิบัติกำรท่ีต้องกำรติดต้ังจำกหัวข้อต่อไปนี ้

1. Windows Installer 
2. Windows ZIP File for non Admin Install 
3. Mac OS X 10.7 Lion or Newer 
4. Linux 32 Bits 

        

หน่วยที่ 2
Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C 

http://arduino.cc/en/Main/Software
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5 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

5. Linux 64 Bits 
6. Linux ARM (Experimental) 

 

 
 

รูปที่ 2.2 หน้ำต่ำงเลือกระบบปฏิบัติกำร Windows Installer 
 ในท่ีนี้เลือก Windows Installer จำกนั้นเลือก Just Download และรอจนเสร็จเพื่อท่ี Download 
Arduino Software ส ำหรับระบบปฏิบัติกำร Windows  
  หลังจำก Download แล้วให้เลือกท่ีอยู่ของ Downloaded File บนระบบ System และ ท ำกำร Extract 
the Folder จำก Zipped File วำงลงบนต ำแหน่งท่ีเหมำะสม 
 

 
 

รูปที่ 2.3 หน้ำต่ำง Downloaded Zipped File  
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รูปที่ 2.3 หน้ำต่ำงกำรยอมรับ License 
 

 
 

รูปที่ 2.4 หน้ำต่ำงเลือก Destination Folder 
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7 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

 
 

รูปที่ 2.5 หน้ำต่ำงเลือกรูปแบบกำร Installation  
 

 
 

รูปที่ 2.6 หน้ำต่ำงกำร Installation  
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รูปที่ 2.7 หน้ำต่ำงกำรติดต้ังส ำเร็จ 
 
  2.1.1 กำร Install the Arduino Windows Drivers 

 ท ำกำร Plug the Arduino บอร์ดลงบนเครื่อง PC Windows พยำยำม install drivers แต่
สุดท้ำยก็จะไม่ส ำเร็จ 

 Start the Windows Device Manager ให้ Click ไปท่ีปุ่ม Start Menu คลิกขวำท่ี 
ท่ี My Computer บน Start Menu แล้ว Click Properties or Manage จำกหน้ำต่ำง 
Menu เพื่อท ำกำรเปิด Device Manager 
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9 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

 
  

รูปที่ 2.8 หน้ำต่ำงกำรเข้ำเมนู Device Manager  

 Click ไปท่ี Device Manager link เพื่อ Start Device Manager 

 
 

รูปที่ 2.9 หน้ำต่ำงกำร Start device Manager 

 Device Manager จะเปิดและแสดง Arduino Device ท่ีเรำท ำกำร Connect ไว้ ขึ้นอยู่กับว่ำใช้
บอร์ดชนิดไหนช่ือก็จะแสดงขึ้นมำให้เห็น 
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รูปที่ 2.10 หน้ำต่ำงอุปกรณ์ Arduino ไม่สำมำรถท ำกำร Install ได้ 
 

 ทีนี้เรำจะเจอเครื่องหมำยตกใจขึ้นสีเหลืองซึ่งแสดงว่ำอุปกรณ์ Arduino นั้นไม่สำมำรถท ำกำร 
Install ได้ มำถึงขั้นนี้ก็ต้องด ำเนินกำรดังต่อไปนี้ 

 2.1.2 Installing the Device Driver 
 ในหน้ำต่ำงของ Device Manager ให้คลิกขวำไปท่ี Arduino บอร์ดแล้วก็ Click Update Driver 
Software บนหน้ำต่ำง Menu 
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รูปที่ 2.11 หน้ำต่ำงกำรเลือก Update Driver Software 
 ณ ขณะนี้จะมีหน้ำต่ำงมำโชว์ว่ำ Update Driver Software  ให้คลิกท่ี Browse my Computer for 
Driver Software เพื่อท่ีจะ Install Driver Software Manually 

 
  

รูปที่ 2.12 หน้ำต่ำงกำรค้นหำ Driver Software 
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 ต่อไป click the Browse button 

 
 

รูปที่ 2.13 หน้ำต่ำงกำรค้นหำ Arduino Driver Folder 

 เลือกไปท่ี Drivers Folder ใน Arduino Folder  ท่ีได้ Download มำ 
 

 
 

รูปที่ 2.14 หน้ำต่ำงกำรเลือก Driver Arduino Folder   

 หลังจำกเลือกไปท่ี Driver Folder เรียบร้อยแล้ว ให้  Click  Next 
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รูปที่ 2.15 หน้ำต่ำงกำรเลือก Driver Folder  

 จะมีกล่องหน้ำต่ำงขื้นมำ Click Install this Driver Software Anyway to Continue the 
Arduino บอร์ด Drivers 

 

 
 

รูปที่ 2.16 หน้ำต่ำงกำรแจ้งเตือน Window Security 

 เมื่อท ำกำร Install Driveเป็นท่ีเรียบร้อยแล้วจะมี dialog box ตำมรูปข้ำงล่ำงเรำต้องทรำบพอร์ต 
number ท่ีบอร์ด Arduino เรำท ำกำรเช่ือมต่ออยู่ในตัวอย่ำงนี้คือ COM3 แต่บอร์ดท่ีใช้งำนจริง
อำจจะมำเป็น  COM อื่นๆ ก็ได้ 
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รูปที่ 2.17 หน้ำต่ำงกำร Install Driver เรียบร้อย   

 ถ้ำเห็นข้อควำมนี้แสดงว่ำได้ท ำกำร Install Driver เป็นท่ีเรียบร้อยแล้ว ก็ท ำกำร Close ได้ 
 
 2.1.3 ท ำกำร Setup Arduino Software  
 หลังจำก Installation แล้วกำร Set นี้ ท ำแค่ครั้งเดียวเป็นอันเสร็จ นอกเสียจำกต้องกำรเปล่ียนรุ่นของ
บอร์ดหรือเปล่ียนพอร์ตท่ีท ำกำรเช่ือมต่อกับบอร์ดเท่ำนั้น เพียงแค่เลือกไปท่ี Folder ท่ีได้เก็บ Arduino IDE ไว้ 
และท ำกำร Start Software ของ Arduino IDE โดยท ำกำร Double Click ไปท่ี Arduino Application 
 

 
รูปที่ 2.18 หน้ำต่ำงที่อยู่ของไอคอน Arduino IDE 
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 Double Click ท่ี Arduino.exe เพื่อ Start Arduino IDE จำกนั้นเลือกรุ่นของ Arduino บอร์ดท่ี
ท ำกำรเช่ือมต่อให้ถูกต้องจำกใน list ท ำกำรเปล่ียนถ้ำจ ำเป็น 

 

 
 

รูปที่ 2.19 กำรเลืกบอร์ด Arduino ในกำรเชื่อมต่อ 

 หลังจำกนั้นก็ท ำกำรเช็คว่ำ serial พอร์ตท่ีต่ออยู่ได้ถูกเลือกอย่ำงถูกต้อง เลือกไปท่ี Computer 
Serial พอร์ตท่ี Arduino ท ำกำรต่อเช่ือมอยู่  

  
 
 

 
 
 
 
 
 

 
 
 
 

http://www.arduitronics.com/category/2/development-boards/
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2.2 ลักษณะโดยทั่วไปของโปรแกรม Arduino IDE 
เมื่อเรียกให้โปรแกรมท ำงำนจะมีหน้ำตำดังรูปท่ี 2.20  ตัวโปรแกรมประกอบด้วยส่วนต่ำงๆ ดังนี้ 

1. เมนู (Menu) ใช้เลือกค ำส่ังต่ำงๆ ในกำรใช้งำนโปรแกรม 
2. แถบเครื่องมือ (Toolbar) เป็นกำรน ำค ำส่ังท่ีใช้งำนบ่อยๆ มำสร้ำงเป็นปุ่มเพื่อให้เรียกใช้ค ำส่ั งได้รวดเร็วขึ้น  
3. แถบเลือกโปรแกรม (Tabs) เป็นแถบท่ีใช้เลือกไฟล์โปรแกรมแต่ละตัว (กรณีท่ีเขียนโปรแกรมขนำดใหญ่

ประกอบด้วยไฟล์หลำยตัว 
 

 
 

รูปที่ 2.20 ลักษณะโดยทั่วไปของโปรแกรม Arduino IDE 
4. พื้นท่ีเขียนโปรแกรม (Text Editor) เป็นพื้นท่ีส ำหรับเขียนโปรแกรมภำษำ C/C++ 
5. พื้นท่ีแสดงสถำนะกำรท ำงำน (Message Area) เป็นพื้นท่ีโปรแกรมใช้แจ้งสถำนะกำรท ำงำนของ 

โปรแกรม เช่นผลกำรคอมไพล์โปรแกรม 
6. พื้นท่ีแสดงข้อมูล (Text Area) ใช้แจ้งว่ำโปรแกรมที่ผ่ำนกำรคอมไพล์แล้วมีขนำดกี่ไบต์ 
7. ปุ่มส ำหรับเปิดหน้ำต่ำง Serial Monitor ปุ่มนี้จะอยู่ทำงมุมบนด้ำนขวำมือ คลิกปุ่มนี้เมื่อต้อง 

กำรเปิดหน้ำต่ำงส่ือสำรและแสดงข้อมูลอนุกรม โดยต้องมีกำรต่อฮำร์ดแวร์ Arduino และเลือกพอร์ตกำรเช่ือม 
ต่อให้ถูกต้องก่อน 
 



 

หน่วยที่ 2 Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                                             เรียบเรียงโดยครูทันพงษ์  ภู่รักษ ์

 

17 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

 
 

รูปที่ 2.21 ลักษณะของหน้ำต่ำง Serial Monitor  
       หน้ำต่ำง Serial Monitor มีบทบำทค่อนข้ำงมำกในกำรใช้แสดงผลกำรท ำงำนของโปรแกรมแทนกำรใช้ 
อุปกรณ์แสดงผลอื่นๆ เนื่องจำก Arduino ได้เตรียมค ำส่ังส ำหรับใช้แสดงค่ำของตัวแปรท่ีต้องกำรดูผลกำรท ำงำนไว้ 
แล้วนั่นคือ Serial.print ส่วนกำรส่งข้อมูลจำกคอมพิวเตอร์ ไปยังฮำร์ดแวร์ Arduino หรือแผงวงจรควบคุมให้     
พิมพ์ข้อควำมและคลิกปุ่ม Send ในกำรรับส่งข้อมูลต้องก ำหนดอัตรำเร็วในกำรถ่ำยทอดข้อมูลหรือบอดเรต (baud 
rate) ให้กับโปรแกรมในค ำส่ัง Serial.begin กรณีท่ีใช้งำนกับคอมพิวเตอร์ Mcintosh หรือคอมพิวเตอร์ท่ีติด        
ต้ังระบบปฏิบัติกำร Linux ตัวฮำร์ดแวร์ของ Arduino จะรีเซ็ตเมื่อเริ่มเปิดใช้งำน Serial monitor 
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 2.3 เมนูบำร์แสดงรำยกำรของค ำสั่ง 
  เมนู File ใน Arduino จะเรียกโปรแกรมท่ีพัฒนำขึ้นว่ำสเก็ตช์ (Sketch) ในโปรแกรมของผู้ใช้งำนอำจมีไฟล์
โปรแกรมหลำยตัว จึงเรียกรวมว่ำเป็นสเก็ตช์บุ๊ก (Sketchbook) เมนูนี้จะเกี่ยวข้องกับกำรเปิด-บันทึก-ปิดไฟล์มี
ค ำส่ังท่ีควรทรำบและเกี่ยวข้องกับบอร์ด Arduino ดังนี้ 
 

2.3.1 เมนู File 

 
 

  New : ใช้สร้ำงไฟล์สเก็ตช์ตัวใหม่เพื่อเริ่มเขียนโปรแกรมใหม่ 

  Open : ใช้เปิดสเก็ตช์ท่ีบันทึกไว้ก่อนหน้ำนี้ 

  Sketchbook : ใช้เปิดไฟล์สเก็ตช์ล่ำสุดท่ีเปิดใช้งำนเสมอ 

  Example : ใช้ในกำรเลือกเปิดไฟล์สเก็ตช์ตัวอย่ำงท่ีบรรจุและรวบรวมไว้ใน     
 โฟลเดอร์ของ Arduino 

  Save : ใช้ในกำรบันทึกไฟล์สเก็ตช์ปัจจุบัน 

  Save As : ใช้บันทึกไฟล์สเก็ตช์โดยเปล่ียนช่ือไฟล์ 

  Upload to I/O บอร์ด : ใช้อัปโหลดโปรแกรมไปยังแผงวงจร Arduino หรือ   
 ฮำร์ดแวร์ ของ Arduino 

  Page Setup : ต้ังค่ำหน้ำกระดำษของไฟล์สเก็ตช์ปัจจุบัน 

  Print : ส่ังพิมพ์โค้ดของไฟล์สเก็ตช์ปัจจุบันออกทำงเครื่องพิมพ์ 

  Preference : ใช้ก ำหนดค่ำกำรท ำงำนของโปรแกรม 

  Quit : ใช้จบกำรท ำงำนและออกจำกโปรแกรม 
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2.3.2  เมนู Edit 
 ในขณะท่ีพิมพ์โปรแกรมใช้ค ำส่ังในเมนูนี้ในกำรส่ังยกเลิกค ำส่ังท่ีแล้วท ำซ ้ำและอื่นมีรำยกำรค ำส่ังต่ำงๆท่ี
ควรทรำบดังนี้ 

 
 

  Undo : ยกเลิกค ำส่ังหรือกำรพิมพ์ครั้งสุดท้ำย 

  Redo : ท ำซ ้ำค ำส่ังหรือกำรพิมพ์ครั้งสุดท้ำย 

  Cut : ตัดข้อควำมท่ีเลือกไว้ไปเก็บในคลิบอร์ดของโปรแกรม 

  Copy : คัดลอกข้อควำมท่ีเลือกไว้มำเก็บในคลิปบอร์ด 

  Paste : น ำข้อควำมท่ีอยู่ในคลิปบอร์ดมำแปะลงในต ำแหน่งท่ีเคอร์เซอร์ช้ีอยู่ 

  Select All : เลือกข้อควำมท้ังหมด 

  Comment/Uncomment : ใช้เติมเครื่องหมำย // เพื่อสร้ำงหมำยเหตุหรือ
ค ำอธิบำยลงในโปรแกรมและยกเลิกด้วยเครื่องหมำย // ออก  
 

2.3.3 เมนู Sketch 
 เป็นเมนูท่ีบรรจุค ำส่ังท่ีใช้ในกำรคอมไพล์โปรแกรมเพิ่มไฟล์ไลบรำรี ฯลฯ โดยมีเมนูย่อยดังนี้ 

 



 

หน่วยที่ 2 Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                                             เรียบเรียงโดยครูทันพงษ์  ภู่รักษ ์
 

20 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  
 

 

  Verify/Compile : ใช้คอมไพล์แปลโปรแกรมภำษำซีให้เป็นภำษำเครื่อง 

  Show Sketch folder : ส่ังเปิดโฟลเดอร์ท่ีเก็บโปรแกรมของผู้ใช้ 

  Add File : เพิ่มไฟล์ให้กับสเก็ตช์บุ๊กปัจจุบัน เมื่อใช้ค ำส่ังนี้ โปรแกรม Arduino จะ   
 ท ำกำรคัดลอกไฟล์ท่ีเลือกไว้มำเก็บไว้ในโฟลเดอร์เดียวกันกับโปรแกรมที่ก ำลัง  
 พัฒนำ 

 Import Library : เป็นค ำส่ังเรียกใช้ไลบรำรีเพิ่มเติมเมื่อคลิกเลือกค ำส่ังนี้แล้ว
โปรแกรม Arduino IDE แสดงไลบรำรีให้เลือก เมื่อเลือกแล้วโปรแกรมจะแทรก
บรรทัดค ำส่ัง #include ลงในส่วนต้นของไฟล์ 
 

2.3.4 เมนู Tools 
 ใช้จัดรูปแบบของโค้ดโปรแกรม เลือกรุ่นของฮำร์ดแวร์ Arduino และเลือกพอร์ตท่ีติดต่อเมนูท่ีใช้งำนกับ
บอร์ด Arduino มีดังนี้ 
 

 
 

 Auto Format : จัดรูปแบบของโค้ดโปรแกรมให้สวยงำม 

 Archive Sketch : ส่ังบีบอัดไฟล์โปรแกรมท้ังโฟลเดอร์หลักและโฟลเดอร์ย่อยของ
ไฟล์สเก็ตช์ปัจจุบันไฟล์ท่ีสร้ำงใหม่จะมีช่ือเดียวกับไฟล์สเก็ตช์ปัจจุบัน 

 Board : เลือกฮำร์ดแวร์ของบอร์ไมโครคอนโทรลเลอร์ Arduino  

 Serial Port : เลือกหมำยเลขพอร์ตของคอมพิวเตอร์ท่ีต่อกับฮำร์ดแวร์ Arduino 
และบอร์ด Arduino 
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2.3.5 เมนู Help 
 เมื่อต้องกำรควำมช่วยเหลือหรือข้อมูลเกี่ยวกับโปรแกรมให้เลือกเมนูนี้เมื่อเลือกเมนูย่อยตัวโปรแกรมจะ     
เปิดไฟล์เว็บเพจ (ไฟล์นำมสกุล .html) ท่ีเกี่ยวข้องกับหัวข้อนั้นๆโดยไฟล์จะเก็บในเครื่องของผู้ใช้ภำยในโฟลเดอร์ท่ี 
เก็บ Arduino IDE 

 
 

 2.4 กำรทดสอบกำรท ำงำนบอร์ด Arduino เบื้องต้น 
 ค ำส่ังท่ีมีกำรใช้ในตัวโปรแกรม Arduino จะน ำมำสร้ำงเป็นปุ่มบนแถบเครื่องมือเพื่อให้สำมำรถคลิกเลือกได้
ทันทีปุ่มต่ำงๆ บนแถบเครื่องมือมีดังนี้  

 Verfy/Compile ใช้ตรวจสอบกำรเขียนค ำส่ังในโปรแกรมว่ำถูกต้องตำมหลักไวยกรณ์หรือไม่ และ
คอมไพล์ โปรแกรม  

 Upload to I/O บอร์ด ใช้อัปโหลดโปรแกรมท่ีเขียนขึ้นไปยังบอร์ดหรือฮำร์ดแวร์ Arduino ก่อน
จะอัปโหลดไฟล์ต้องแน่ ใจว่ำได้บันทึกไฟล์ และคอมไพล์ไฟล์สเก็ตช์เรียบร้อยแล้ว  

 New ใช้สร้ำงสเก็ตไฟล์ (ไฟล์ โปรแกรม) ตัวใหม่  

 Open ใช้แทนเมนู File > Sketchbook เพื่อเปิดสเก็ตช์ (ไฟล์ โปรแกรม) ท่ีมีในเครื่อง Save ใช้
บันทึกไฟล์สเก็ตชบุ๊กท่ีเขียนขึ้น 

 

 
 

รูปที่ 2.22 กำรเลือกชนิดของบอร์ด Arduino ที่ต่อใช้งำน 
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 เลือกบอร์ด Arduino โดยเลือกจำกเมนู Tools > Bord โปรแกรมจะแสดงบอร์ดท่ีมีใน 
                    คอมพิวเตอร์ให้ผู้ใช้งำน 
 

 
 

รูปที่ 2.23 หน้ำต่ำงกำรเลือกพอร์ต Arduino 

 เลือกพอร์ตท่ีใช้เช่ือมต่อกับบอร์ด Arduino โดยเลือกจำกเมนู Tools > Serial พอร์ตโปรแกรมจะ
แสดงพอร์ตท่ีมีในคอมพิวเตอร์ให้ผู้ใช้งำนเลือกในตัวอย่ำงเลือกพอร์ต COM3 

 จำกนั้นพิมพ์โค้ดต่อไปนี้ 

 
อัปโหลดโปรแกรมไปยังบอร์ด Arduino โดยคลิกท่ีปุ่ม Upload หรือเลือกท่ีเมนู File > Upload รอ

จนกระท่ังกำรอัปโหลดเสร็จส้ิน บอร์ดจะท ำงำนทันที LED ติดกะพริบทุกๆ 1 วินำที เป็นอันเสร็จส้ินกำรทดสอบ
กำรเขียนและอัปโหลดโปรแกรมเบื้องต้นกับบอร์ด Arduino ถ้ำเกิดกำรอัปโหลดโปรแกรมผิดพลำดจะส่งผลให้
บอร์ด Arduino ใช้งำนไม่ได้ ต้องตรวจสอบดูจำกข้อควำมสีส้มด้ำนล่ำงว่ำผิดพลำดจำกอะไร 
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รูปที่ 2.24 หน้ำต่ำงแสดงกำรอัพโหลดโปรแกรมเสร็จเรียบร้อย 
เมือ่คอมไพล์โปรแกรมแล้วท่ีแถบแสดงสถำนะและหน้ำต่ำงแสดงผลกำรคอมไพล์ ซึ่งเป็นหน้ำต่ำงสีด ำอยู่

ด้ำนล่ำงของโปรแกรมท่ีแถบแสดงสถำนะจะปรำกฏข้อควำม Done Compiling และหน้ำต่ำงแสดงผลแสดง
ข้อควำมว่ำ Binary Sketch Size: 4,830 bytes (of a 28,672 Byte Maximum) แสดงว่ำโปรแกรมภำษำเครื่องท่ี
จำกกำรคอมไพล์มีขนำด 4,830 ไบต์จำกควำมจุของหน่วยควำมจ ำของท้ังหมดท่ีใช้งำนได้ 28,672 ไบต์ 
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สรุปเนื้อหำสำระส ำคัญ 

  
 IDE ย่อมำจำก (Integrated Development Environment) คือ ส่วนเสริมของระบบกำรพัฒนำหรือตัว
ช่วยต่ำงๆท่ีจะคอยช่วยเหลือ Developer หรือช่วยเหลือคนท่ีพัฒนำ Application เพื่อเสริมให้เกิดควำมรวดเร็ว 
ถูกต้อง แม่นย ำ ตรวจสอบระบบท่ีจัดท ำได้ ท ำให้กำรพัฒนำงำนต่ำงๆเร็วมำกขึ้น  หน้ำต่ำง Serial Monitor มี
บทบำทค่อนข้ำงมำกในกำรใช้แสดงผลกำรท ำงำนของโปรแกรมแทนกำรใช้อุปกรณ์แสดงผลอื่นๆ เนื่องจำก 
Arduino ได้เตรียมค ำส่ังส ำหรับใช้แสดงค่ำของตัวแปรท่ีต้องกำรดูผลกำรท ำงำนไว้ แล้วนั่นคือ Serial.print ส่วน
กำรส่งข้อมูลจำกคอมพิวเตอร์ ไปยังฮำร์ดแวร์ Arduino หรือแผงวงจรควบคุมให้พิมพ์ข้อควำมและคลิกปุ่ม Send 
ในกำรรับส่งข้อมูลต้องก ำหนดอัตรำเร็วในกำรถ่ำยทอดข้อมูลหรือบอดเรต (baud rate) ให้กับโปรแกรมในค ำส่ัง 
Serial.begin  
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เร่ือง  Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                                              ใช้เวลำ 20 นำที  
******************************************************************************************************* 
ค ำช้ีแจง  1. แบบฝึกหัดมีท้ังหมด 2 ตอน ประกอบด้วยตอนท่ี 1 และตอนท่ี 2 (20 คะแนน) 
             2. แบบฝึกหัดตอนท่ี 1 เป็นค ำถำมแบบถูก-ผิด มีท้ังหมด 20 ข้อ (10 คะแนน)  
      3. แบบฝึกหัดตอนท่ี 2 เป็นค ำถำมแบบปรนัย มีท้ังหมด 10 ข้อ (10 คะแนน) 
 

                                         
 
ค ำช้ีแจง    ให้ผู้เรียนกำเครื่องหมำยถูก  ในข้อท่ีคิดว่ำถูก และกำเครื่องหมำยผิด  ในข้อท่ีคิดว่ำผิด 
 
        1.ซอฟต์แวร์ท่ีใช้ในกำรพัฒนำงำนส ำหรับบอร์ด Arduino คือโปรแกรมท่ีเรียกว่ำ Arduino DEI 
        2. ขนำดของโปรแกรม Arduino โดยปกติแล้วจะใหญ่กว่ำโค้ด AVR 
             3. โค้ด AVR เป็นกำรเข้ำถึงจำกรีจิสเตอร์โดยตรง 
        4. โค้ด Arduino เข้ำถึงผ่ำนรีจิสเตอร์ 
        5. โหลดโปรแกรม IDE ฟรีท่ีเวป http://Arduino.cc/en/Main/Software          
        6. Windows พยำยำม Install Drivers แต่สุดท้ำยก็ส ำเร็จ 

    7. เมนู (Menu) ใช้เลือกค ำส่ังต่ำงๆ ในกำรใช้งำนโปรแกรม 
        8. แถบเครื่องมือ (Toolbar) เป็นกำรน ำค ำส่ังท่ีใช้งำนนำนๆครั้ง มำสร้ำงเป็นปุ่ม 
       9. แถบเลือกโปรแกรม (Tabs) เป็นแถบท่ีใช้เลือกไฟล์โปรแกรมแต่ละตัว 

    10. พื้นท่ีเขียนโปรแกรม (Text Editor) เป็นพื้นท่ีส ำหรับเขียนโปรแกรมภำษำ C/C++ 
 
 
 
 
 
 
 
 

 

   แบบฝึกหัดหน่วยท่ี 2 
 

แบบฝึกหัดตอนที่ 1 
 

http://arduino.cc/en/Main/Software
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ค ำช้ีแจง    ให้ผู้เรียนเลือกค ำตอบท่ีถูกท่ีสุดแล้วกำเครื่องหมำยกำกบำท () ให้ครบทุกข้อ 
 
1. โปรแกรม IDE คือ 

ก.  ตัวช่วยต่ำงๆเพื่อเสริมให้เกิดควำมรวดเร็ว ถูกต้อง แม่นย ำ ท ำให้กำรพัฒนำงำนเร็วมำกขึ้นนั่น 
ข.  กำร Plug the Arduino บอร์ด ลงบนเครื่อง PC 
ค.  Installing the Device Driver 
ง.  Install Driver Software Manually 

2. เครื่องหมำยตกใจสีเหลืองท่ี Device Manager หมำยถึงอะไร  
ก.   Windows ไม่มีลิขสิทธิ์ 
ข.   แสดงว่ำอุปกรณ์ Arduino นั้นไม่สำมำรถท ำกำร Install ได้ 
ค.   หน่วยประมวลผลกลำงมีไมโครโปรเซสเซอร์ท ำหน้ำท่ีประมวลผลข้อมูลและควบคุม 
ง.    มีควำมหมำยเดียวกันกับไมโครคอมพิวเตอร์ 

3. ข้อควำมใดแสดงว่ำได้ท ำกำร Install Driver Arduino เป็นท่ีเรียบร้อยแล้ว 
     ก.  Setup Arduino Software 
     ข.  Windows has Successfully Updated your Driver Software 
     ค.  Start Arduino IDE 

ง.  Double Click  "Arduino.exe" 
4. พื้นท่ีเขียนโปรแกรม (Text Editor) เป็นพื้นท่ีส ำหรับเขียนโปรแกรมภำษำ 

ก.   ภำษำ เบสิค   
ข.   ภำษำ C/C++   
ค.   ภำษำ แอสแซมบล้ี   
ง.   ภำษำ อังกฤษ 

5. เมนู File > Sketchbook  ใช้ส ำหรับ 
ก.   ใช้เปิดไฟล์สเก็ตช์ล่ำสุด 
ข.   ใช้สร้ำงไฟล์สเก็ตช์ตัวใหม่ 
ค.   ใช้บันทึกไฟล์สเก็ตช์ปัจจุบัน         
ง.   ใช้อัปโหลดโปรแกรม 
 
 
 

แบบฝึกหัดตอนที่ 2 
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6. เมนู Edit > Redo ใช้ส ำหรับ 
       ก.   ยกเลิกค ำส่ังหรือกำรพิมพ์ครั้งสุดท้ำย 
       ข.   ตัดข้อควำมท่ีเลือกไว้ไปเก็บในคลิบอร์ด 

              

       ค.   เลือกข้อควำมท้ังหมด 
       ง.   ท ำซ ้ำค ำส่ังหรือกำรพิมพ์ครั้งสุดท้ำย 

       

7. เมนู Sketch > Verify/Compile ใช้ส ำหรับ 
       ก.   ส่ังเปิดโฟลเดอร์ท่ีเก็บโปรแกรมของผู้ใช้ 
       ข.   เพิ่มไฟล์ให้กับสเก็ตช์บุ๊กปัจจุบัน                        
       ค.   ใช้คอมไพล์แปลโปรแกรมภำษำซีให้เป็นภำษำเครื่อง                         
       ง.   เป็นค ำส่ังเรียกใช้ไลบรำรีเพิ่มเติม 
8. เมนู Tools > Serial พอร์ตใช้ส ำหรับ 
       ก.   เลือกหมำยเลขพอร์ตของคอมพิวเตอร์ท่ีต่อกับฮำร์ดแวร์  
       ข.   จัดรูปแบบของโค้ดโปรแกรมให้สวยงำม      
       ค.   ส่ังบีบอัดไฟล์ โปรแกรมท้ังโฟลเดอร์หลักและโฟลเดอร์ย่อย      
       ง.   เลือกฮำร์ดแวร์ของบอร์ไมโครคอนโทรลเลอร์ Arduino 

        

9. เมื่อคอมไพล์โปรแกรมทดสอบกำรท ำงำนบอร์ด Arduino แล้วที่แถบแสดงสถำนะปรำกฏข้อควำม 
       ก.   Done Compiling 
       ข.   Ok Compiling 

        

       ค.   Good Compiling 
       ง.    Excellent Compiling 

        

10. โดยปกติค่ำ Baud Rate ท่ีนิยมใช้คือ   
  ก.   4800 
  ข.   9600 
  ค.   19.25 K 
  ง.    62.5  K 
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***************************************************************************************************
ค ำช้ีแจง ให้ผู้เรียนทุกคนท ำกำรทดลองตำมปฎิบัติกำรทดลองหน่วยท่ี 2 เรื่อง กำรติดต้ังและทดสอบ Arduino 
Uno R3 โดยใช้เวลำ 60 นำที ( 20 คะแนน) 

 
 จุดประสงค์เชิงพฤติกรรม  

1. สำมำรถติดต้ังและทดสอบบอร์ด Arduino Uno R3 ได้ 
2. สำมำรถแก้ปัญหำท่ีท ำให้กำรติดต้ังไม่ส ำเร็จ ในกำรติดต้ังบอร์ด Arduino Uno R3 ได้  
3. สำมำรถทดสอบกำรท ำงำนของบอร์ด Arduino Uno R3 ได้ 

         
อุปกรณ ์กำรทดลอง 

  1. โปรแกรม Arduino IDE 1.6.9    1  โปรแกรม 
 2. สำยโหลด USB Arduino Uno R3   1  เส้น 
 3. บอร์ด Arduino Uno R3    1 บอร์ด 
 4. สำยต่อวงจร      1  ชุด 
 5. เครื่องคอมพิวเตอร์    1 เครื่อง 

6. แผงต่อวงจร     1 ตัว 
   
     ข้อควรระวัง 
 1. ควรระวังไม่วำงบอร์ด Arduino Uno R3 หรือชีลต่ำงๆ บนโต๊ะโลหะหรือท่ีวำงท่ีเป็นโลหะเพรำะอำจเกิด
กำรลัดวงจรของภำคจ่ำยไฟได้ 

2. ไม่ควรต่อสำยต่อวงจรในบอร์ด Arduino Uno R3 ท้ิงไว ้ ควรถอดสำยต่อวงจรออกให้หมด เพรำะผล
กำรทดลองอำจเกิดกำรผิดพลำดไม่เป็นไปตำมทฤษฎีได้ 

3. ไม่ควรถอดสำยสำยโหลด USB เข้ำออกตลอดเวลำ เพรำะอำจท ำให้ภำคจ่ำยไฟของบอร์ด Arduino 
Uno R3 เสียหำยได้ 

 
 
 

 
 

 

ปฏิบัติกำรทดลองหน่วยที่ 2 
เร่ือง กำรติดต้ังและทดสอบ Arduino Uno R3 
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วงจรประกอบกำรทดลอง 
 
 

 
 

รูปที่ 2.25 กำรต่อบอร์ด Arduino กับคอมพิวเตอร์ 
ขั้นตอนกำรทดลอง 
 

1. โหลดโปรแกรม IDE ฟรีท่ีเวปhttp://arduino.cc/en/Main/Software กด click ท่ี download เพื่อ 
เข้ำสู่ download page.  
 

 
รูปที่ 2.26 หน้ำต่ำง Download Arduino IDE 

2. เลือกระบบปฏิบัติกำรท่ีต้องกำรติดต้ัง 
 Windows Installer 

 

http://arduino.cc/en/Main/Software
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3. เลือก  Windows Installer จำกนั้นเลือก Just Download และรอจนเสร็จเพื่อท่ีจะ Download  

Arduino Software ส ำหรับระบบปฏิบัติกำร Windows 
 

                 
 

 รูปที่ 2.27 หน้ำต่ำง Download แบบติดต้ังกับระบบ Window 
 

4. หลังจำก Download แล้วให้เลือกท่ีอยู่ของ  Downloaded File บนระบบ System และ ท ำ 
กำร Extract the Folder จำก Zipped File วำงลงบนต ำแหน่งท่ีเหมำะสม 
 

 
 

รูปที่ 2.28 หน้ำต่ำงกำร Extract the Folder จำก Zipped File 
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5. ท่ีหน้ำต่ำง Arduino Setup License Agreement เลือก I Agree  
 

 
 

รูปที่ 2.29 หน้ำต่ำงเลือก License Agreement 
6. หน้ำต่ำง Arduino Setup Installation Folder เลือกโพลเดอร์ท่ีต้องกำรติดต้ัง จำกนั้นคลิก Install 

 

 
 

รูปที่ 2.30 หน้ำต่ำงเลือกที่อยู่ Installation 
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7. หน้ำต่ำง Arduino Setup Installation Option เลือกเช็คบอร์กตำมรำยกำรท่ีต้องกำร จำกนั้นคลิก 
Next คือท ำรำยกำรต่อไป 
 

 
 

รูปที่ 2.31 หน้ำต่ำงกำร Setup Installation Option 
8. Start the Windows Device Manager ให้ Click ไปท่ีปุ่ม Start menu คลิกขวำท่ี  

ท่ี My Computer บน Start menu แล้วก็ Click Properties or Manage จำก Pop-Up Menu เพื่อท ำกำรเปิด
Device Manager และ Click ไปท่ี Device Manager Link เพื่อ Start device Manager: 

 
 

รูปที่ 2.32 หน้ำต่ำงกำร Start device manager 
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9. Device Manager จะเปิดและแสดง Arduino Device ท่ีเรำท ำกำร Connect ไว้ ขึ้นอยู่กับว่ำ 
ใช้บอร์ดชนิดไหนช่ือก็จะแสดงขึ้นมำให้เห็น 

 
 

รูปที่ 2.33 หน้ำต่ำงกำร Start device Manager 
 

 
 

รูปที่ 2.34 หน้ำต่ำงกำรเข้ำเมนู Device Manager  
 

10. เรำจะเจอเครื่องหมำยตกใจขึ้นสีเหลืองซึ่งแสดงว่ำอุปกรณ์ Arduino นั้นไม่สำมำรถท ำกำร Install ได้  
มำถึงขั้นนี้ก็ต้อง Installing the Device Driver ในหน้ำต่ำงของ Device Manager, ให้คลิกขวำไปท่ี Arduino 
บอร์ด แล้วก็ Click Update Driver Software, บน Pop-Up Menu 
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รูปที่ 2.35 หน้ำต่ำงแสดงกำร click Update Driver Software  
ขณะนี้จะมีกล่องขึน Pop-Up มำโชว์ว่ำ Update Driver Software  ให้คลิกท่ี Browse  

My Computer for Driver Software เพื่อท่ีจะ Install Driver Software Manually 

 
  

รูปที่ 2.36 หน้ำต่ำงกำร install Driver Software Manually 
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 ต่อไป Click Browse My Computer for Driver Software Button 
 

 
 

รูปที่ 2.37 หน้ำต่ำงกำรค้นหำ Driver Software 
 เลือกไปท่ี Drivers Folder ใน Arduino Folder  ท่ีได้ Download มำ 
 

 
 

รูปที่ 2.37 หน้ำต่ำงกำรค้นหำ Driver Software 
 หลังจำกเลือกไปท่ี Driver Folder เรียบร้อยแล้ว ให้  Click  Next 
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รูปที่ 2.38 หน้ำต่ำงกำรค้นหำ Arduino Driver Folder 
11. มีหน้ำต่ำงขื้นมำ, Click Install this Driver Software Anyway, to Continue the Arduino  

บอร์ด Drivers 
 

 
 

รูปที่ 2.39 หน้ำต่ำงกำรเลือก Install this driver software 
12. เมื่อท ำกำร Install Drive เป็นท่ีเรียบร้อยแล้วจะมี  Dialog Box ตำมรูปข้ำงล่ำงเรำต้องทรำบ  พอร์ต 

Number ท่ีบอร์ด Arduino เรำท ำกำรเช่ือมต่ออยู่ในตัวอย่ำงนี้คือพอร์ต COM3 แต่บอร์ดท่ีใช้งำนจริงอำจจะมำ
เป็นพอร์ตCOM อื่นๆ กไ็ด้ 
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รูปที่ 2.40 หน้ำต่ำงข้อควำมแสดงว่ำได้ท ำกำร Install Driver เป็นทีเ่รียบร้อยแล้ว   
13. ถ้ำเห็นข้อควำมนี้แสดงว่ำได้ท ำกำร Install Driver เป็นท่ีเรียบร้อยแล้ว  ก็ท ำกำร Close ได้ 

ท ำกำร Set up Arduino Software หลังจำก Installation แล้วกำร set นี้ ท ำแค่ครั้งเดียวเป็นอันเสร็จนอกเสีย
จำกต้องกำรเปล่ียนรุ่นของบอร์ด หรือเปล่ียนพอร์ตท่ีท ำกำรเช่ือมต่อกับบอร์ดเท่ำนั้น เพียงแค่เลือกไปท่ี  folder  ท่ี
ได้เก็บ Arduino IDE ไว้ และท ำกำร StartSoftware ของ Arduino IDE โดยท ำกำร double-Clicking ไป
ท่ี Arduino Application.  

14. Double Click ท่ี Arduino.exe เพื่อ Start Arduino IDE จำกนั้นเลือกรุ่นของ Arduino บอร์ดท่ี 
ท ำกำรเช่ือมต่อให้ถูกต้องจำกใน List ท ำกำรเปล่ียนถ้ำจ ำเป็น 

 
รูปที่ 2.41 หน้ำต่ำงแสดงไอคอน Arduino.exe 
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รูปที่ 2.42 หน้ำต่ำงกำรเลือกบอร์ด Arduino 
15. หลังจำกนั้นก็ท ำกำร check ว่ำ serial พอร์ตท่ีต่ออยู่ได้ถูกเลือกอย่ำงถูกต้อง เลือกไปท่ี Computer 

Serial พอร์ตท่ี Arduino ท ำกำรต่อเช่ือมอยู่ เลือกบอร์ด Arduino โดยเลือกจำกเมนู Tools > Bord โปรแกรมจะ
แสดงบอร์ดท่ีมีในคอมพิวเตอร์ให้ผู้ใช้งำน 
 

 
 

รูปที่ 2.43 กำรเลือกพอร์ต Arduino ในกำรเชื่อมต่อ  
เลือกพอร์ตท่ีใช้เช่ือมต่อกับบอร์ด Arduino โดยเลือกจำกเมนู Tools > Serial พอร์ตโปรแกรมจะ 

แสดงพอร์ตท่ีมีในคอมพิวเตอร์ให้ผู้ใช้งำนเลือกในตัวอย่ำงเลือกพอร์ต COM3 จำกนั้นพิมพ์โค้ดต่อไปนี้ 
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16. อัปโหลดโปรแกรมไปยังบอร์ด Arduino โดยคลิกท่ีปุ่ม UPLOAD หรือเลือกท่ีเมนู File > Upload รอ 

จนกระท่ังกำรอัปโหลดเสร็จส้ิน บอร์ดจะท ำงำนทันที LED ติดกะพริบทุกๆ 1 วินำที เป็นอัน   เสร็จส้ินกำรทดสอบ
กำรเขียนและอัปโหลดโปรแกรมเบื้องต้นกับบอร์ด Arduino ถ้ำเกิดกำรอัปโหลดโปรแกรมผิดพลำดจะส่งผลให้
บอร์ด Arduino ใช้งำนไม่ได้ต้องตรวจสอบดูจำกข้อควำมสีส้มด้ำนล่ำงว่ำผิดพลำดจำกอะไร 

 

 
 

รูปที่ 2.44 เม่ือเสร็จสิ้นกำร UPLOAD โปรแกรม 
17. เมื่อคอมไพล์โปรแกรมแล้วที่แถบแสดงสถำนะและหน้ำต่ำงแสดงผลกำรคอมไพล์ซึ่งเป็นหน้ำต่ำงสีด ำ 

อยู่ด้ำนล่ำงของโปรแกรมท่ีแถบแสดงสถำนะจะปรำกฏข้อควำม Done compiling และหน้ำต่ำงแสดงผลแสดง
ข้อควำมว่ำ Binary sketch size: 4,830 bytes (of a 28,672 byte maximum) แสดงว่ำโปรแกรมภำษำเครื่องท่ี
จำกกำรคอมไพล์มีขนำด 4,830 ไบต์จำกควำมจุของหน่วยควำมจ ำของท้ังหมดท่ีใช้งำนได้ 28,672 ไบต์ 
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สรุปผลกำรทดลอง 
............................................................................................................................. ..............................................
...........................................................................................................................................................................
............................................................................................................................. ..............................................
............................................................................................................................. ..............................................
...........................................................................................................................................................................
............................................................................................................................. ..............................................
............................................................................................................................. ..............................................
................................................................................... ........................................................................................
............................................................................................................................. .............................................. 
............................................................................................................................. ..............................................
...........................................................................................................................................................................
............................................................................................................................. ..............................................
............................................................................................................................. .............................................. 

 
ปัญหำอุปสรรคหรือข้อเสนอแนะ 

............................................................................................................................. ..............................................

..................................................................................... ......................................................................................

............................................................................................................................. ..............................................

............................................................................................................................. .............................................. 
 
ตำรำงกำรประเมินผลคะแนนภำคปฏิบัติ 

 
หัวข้อกำรพิจำรณำภำคปฏิบัติ ระดับคะแนน 

1.สำมำรถติดต้ัง driver Arduino Uno R3 ได้ถูกต้อง 10 คะแนน 
2.สำรถทดสอบกำรท ำงำน Arduino Uno R3 ได้ถูกต้อง  5 คะแนน 
3.สำมำรถสรุปสำระส ำคัญของกำรทดลองได้ กระชับ ครอบคลุมและ
ถูกต้อง 

5 คะแนน 

 
รวมคะแนนภำคปฏิบัติ 

   
  .........คะแนน 

 
 



 

หน่วยที่ 2 Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                                             เรียบเรียงโดยครูทันพงษ์  ภู่รักษ ์

 

41 เอกสำรประกอบกำรสอนวิชำไมโครคอนโทรลเลอร์เบื้องต้น  

********************************************************************************** 

 
 

เร่ือง   Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C                  ใช้เวลำ 20 นำที 
วิชำ   ไมโครคอนโทรลเลอร์เบื้องต้น                 รหัสวิชำ (2127-2107)                                                                          
ระดับชั้น  ประกำศนียบัตรวิชำชีพ (ปวช.)                                            สำขำวิชำ เมคคำทรอนิกส์ 
 
ค ำช้ีแจง    1. แบบทดสอบมีทั้งหมด 10 ข้อ (10 คะแนน)  
        2. ให้ผู้เรียนเลือกค ำตอบที่ถูกที่สุดแล้วกำเคร่ืองหมำยกำกบำท () ลงในกระดำษค ำตอบ 
 
1. กำรติดต้ัง Arduino IDE ต้องไป Download ท่ีใด 
       ก.    Arduinoall.cc 
       ข.    Arduinotronic.cc   
       ค.    Arduino.cc 
       ง.    Arduinothailand.cc 
2. เมื่อพบเครื่องหมำยตกใจสีเหลืองท่ี Device Manager ต้องท ำอย่ำงไร 
       ก.   ไม่สำมำรถท ำอะไรได้อีกแล้ว  
       ข.   แจ้งบริษัทผู้ผลิต 
       ค.   Update Window 
       ง.    Update Driver Software   
3. โปรแกรม Arduino IDE โดย IDE ย่อมำจำก 
        ก.   Integer development environment 
        ข.   Integral development environment 
        ค.   Integrated development environment 
        ง.    Intent development environment 
4. เมนู File ใน Arduino จะเรียกโปรแกรมท่ีสร้ำงขึ้นใหม่ว่ำอะไร 
       ก.   Facebook                      
       ข.   Notebook 
       ค.   Handbook                                
       ง.   Sketchbook 
 

 

แบบทดสอบหลังเรียน หน่วยที่ 2 
เร่ือง Arduino IDE ซอฟต์แวร์ส ำหรับโปรแกรมภำษำ C 
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5. สัญลักษณ์ของเครื่องหมำย Comment ตรงกับข้อใด 
       ก.   //  
       ข.   --                         
       ค.   ++                         
       ง.   ** 
6. เมนู File > Example  ใช้ส ำหรับ 
       ก.   ใช้ก ำหนดค่ำกำรท ำงำนของโปรแกรม 
       ข.   ใช้ในกำรเลือกเปิดไฟล์ Sketch ตัวอย่ำงท่ีบรรจุและรวบรวมไว้ 
       ค.   ใช้สร้ำงไฟล์ Sketch ตัวใหม่เพื่อเริ่มเขียนโปรแกรมใหม่ 
       ง.   ใช้เปิดไฟล์ Sketch ล่ำสุดท่ีเปิดใช้งำนเสมอ 
7. กำรตรวจสอบพอร์ตท่ีต่อใช้งำน ถูกต้องหรือไม่ต้องตรวจสอบท่ีใด 
 ก.  tool > bord   
 ข.  tool > serial Monitor 
 ค.  tool > serial Port    
        ง.  tool > Port 
8. เมนู Tools > Board ใช้ส ำหรับ 
        ก.   เลือกหมำยเลขพอร์ตของคอมพิวเตอร์ท่ีต่อกับฮำร์ดแวร์  
        ข.   จัดรูปแบบของโค้ดโปรแกรมให้สวยงำม      
        ค.   ส่ังบีบอัดไฟล์ โปรแกรมท้ังโฟลเดอร์หลักและโฟลเดอร์ย่อ  
        ง.   เลือกฮำร์ดแวร์ของบอร์ไมโครคอนโทรลเลอร์ Arduino 
9. ค ำส่ังใดเป็นค ำสังหน่วงเวลำ 
        ก.   pin mode 
        ข.   delay  
        ค.   output 
        ง.   digital Write         
10. บอดเรต (baud rate) คือ 
 ก.   หน่วยควำมจ ำส ำหรับเก็บโปรแกรมแบบแฟลช (ROM) 
        ข.   อัตรำเร็วในกำรรับส่งข้อมูลทีต้องก ำหนดค่ำ 
 ค.   ตัวฮำร์ดแวร์ของ Arduino 
 ง.   พอร์ตอินพุตเอำต์พุตให้ใช้งำนจ ำนวน 23 ขำ 
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